Unable to Change 360fly Name/Password


We have received several complaints from customers about no longer being able to alter the camera name or camera WiFi password through the 360fly app. This issue appears to be affecting both 360fly HD and 360fly 4K models, but not for all customers. For customers who are experiencing this issue, there is no option to create a name/password during the setup, and in the camera settings, both of these options are grayed out when the smart phone is connected to the 360fly camera through both Bluetooth and WiFi.

If you are experiencing this issue, please comment below with the following information:

360fly model (HD or 4K)

iPhone or Android

If you are using Android, what is the brand of your smartphone?

What is the specific model of your smartphone?

What version of Android or iOS are you running on your smartphone?

Feel free to include any screenshots or addition information that you think is relevant.

If you don’t feel comfortable posting a public comment, you can email this information to support@360fly.com, but keep in mind that it is easier for engineering to keep track of the information posting on this thread.

If you are experiencing a different issue or feel that you need personalized support, please send an email to support@360fly.com.



360fly model: 4K

iPhone: 7+

iOS: 12.1.2

Comment: Same problem as everyone else experiencing the same. Device name and password is grayed out when smartphone is connected to the device.


Tried 3 different devices with my 360fly 4K.

iPhone: 6
iOS: 12.1.2

iPad: 2018 (6th Gen)
iOS: 12.1

Android: ZTE Blade Q Lux
Android os: 5.0.2


Same as everyone else, I have completed a number of different suggestions to no avail.

Camera: 360fly 4K
Phone : iPhone X version 12.1.2

I have also tried on iPad version 12.1


New 360fly HD received for Christmas and a
3 week old Pixel 3 XL running Android 9 with all patches applied.
When the initial setup had greyed options, I reset the 360fly to factory defaults.
Results are the same as others.
I see a message that the password is the default password. Options to change name and password are greyed out.
No option during setup and greyed out ptions.


Same issue. Cannot change my cameras name or password. Brand new 360fly 4K. I’m using an iPhone XR. iOS 12


Model number 360FLY4k
Firmware revision Z-0099
Hardware revision R1.0
Software revision 1.2.8
App Version 2.1.5

Android Moto X4
Android 9 (PPW29.69-26)
Security patch level November 1, 2018

Rename and change password are grayed out.

Also cannot update: App says "Wi-Fi connection with camera required to install updates despite the fact that i am connected to camera wi fi and can even see live view (downloaded update via LTE)


Is the camera firmware too old to properly work with the latest app release?


just got a 360fly HD from meh.com, can’t change password nor rename the cam, already did a factory reset and currently trying a reformat but it’s been flashing yellow for about 15 minutes now, using a Pixel XL (1st-gen) on the latest software (Android 9.0.0 w/ January 2019 security patch)


360fly HD (360FLYBLK)
Firmware: B-00B8
Software: 1.3.3
Apple iPhone X
iOS 12.1.2


360fly HD (360FLYBLK
Firmware: B-00B8
Software: 1.3.3
Android 9 (January 2019 security patch)
Google Pixel 2 XL

Option to rename, password, or show camera password are all greyed out in the app. When I set it up for the first time, was given no choice in naming it or choosing how to connect to it.


360fly model HD
If you are using Android, what is the brand of your smartphone?
What is the specific model of your smartphone?
Android 8.0


Google Pixel 2
Android 9


Iphone XS Max

When will this be fixed, app is a pia to use and this doesnt make any better. Came from Meh - should return?


360fly 4K will not update, cannot change camera name/wifi pass, will sporadically lose wifi and bluetooth, will glitch in live view

Pixel XL 1, Latest Android 9 with February patches

iPhone x with iOS 12

Pixelbook with Android apps, Android 7 AND 9 - cannot connect to the camera in app, cannot mount camera as drive

Mac OSX Mojave - no option to control or update camera in app

Have attempted multiple factory resets. This has been going on for MONTHS - what is the deal? I have three $500.00 cameras that are USELESS.


Same issue with 360 4K
on iPhone 8+ and iPhone SE
Both version 12.1.4


360fly model HD


Samsung Note 8

What version of Android or iOS are you running on your smartphone? 8.0

Even after resetting the device, it just blinks and the app says booting.


I have two 360fly 4K, and neither will allow changing the camera’s name or password.

Apple Mac OS X - 10.13.4

Ipad & Iphone - both v.12.1.4



Fly 360 HD


One plus 5T

OnePlus A5010

Android 9, Oxygen OS 9.0.4


Same here. Rename and password in grey. On setting up for first time, never given the option to name.

Model #360FLYBLK
Serial: #…3891(obscured by other numbers/overlapping numbers)
Firmware: B-00B8
Hardware: PCB-41
Software: 1.3.3

Samsung Phone: Galaxy S10e
Hardware: REV1.0