360 Fly 4K no power?


#1

Received the 360 fly 4K version today and after reading that I should charge it for at least 30 minutes before using I put it charging. Fast forward 2 hours later and the green light stopped blinking. Now it wont turn on… I tried different chargers and cables but apparently after getting a full charge it stops working. Any fixes before I call support tomorrow?


#2

I am having the same exact problem…a 500 brick.


#3

Had the same problem…the light showed green but then wouldn’t turn on afterward. But support responded to my call quickly and are being very helpful in resolving my issue. Was initially upset but the company is doing what they can to help; I’ll update this when I get my unit working.


#4

Same problem here. Working with Tech support to resolve.


#5

Use a different cable and connect to laptop usb. Mines charging now and maybe in a few hours I can give it a first test.


#6

Fixed my problem. For anyone else having this problem, try using a newer power block with the usb charging cable. Even though the one I used first got the unit to flash green, it didn’t really charge it. I tried a different output (1.8A LG phone usb outlet block instead of an older 0.7A usb outlet block) and it worked just fine.


#7

This is great advice…the newer models need more power than just USB from a computer. Try using power adapter or USB hub that is at least 2.1 amps


#8

I had the same issue over the weekend and just had time today and used a LOWER AMP power charger and its charging now…I called support and they say HIGHER AMPS bricks will DRAIN the power, they are working on a firmware update of the 4k to fix this issue…so it will take a little longer to charge but use a LOWER amp charger for now…


#9

We released a new software release today to allow the device to charge with the higher rate Apple chargers. If you experience an issue with the device not charging, you can charge your device with a charger rated 1.7A or less and it will charge up fully or charge it through the USB port on the computer (takes longer). It may take a few minutes for the green led to come on after putting in on the charger. I recommend installing the latest software release 1.2.8. This will allow you to use the higher rate Apple chargers. Thanks again for the feedback.

Upgrade Instructions


#10

I have the same issue… My camera was working fine till yesterday. It was with almost full battery and I left it for couple of hours for recharging on my pc usb. After that I took it off and tried to switch on but nothing happened… I plugged it in normal phone charger and it started charging again, than after a few minutes I switched it on and connected to my tablet and I saw that the battery is full. I took it off from the charger, took few photos and than the camera switched off suddenly… After that I plugged it again in the charger but it doesn`t actually recharge it… From time to time the camera flashes green 7-10 times and than it stops flashing and I am unable to switch it on even on the recharger… I tried with resetting the camera and again nothing. Any advices?